CCNP Exam Prep Tips and Must Knows about Voice and Video in Campus Networks

studentexamstudy270015

What You Need to Know about Voice and Video in Campus Networks

Components of Unified Communications

  • IP phones
  • Call Agent: Provides call control for IP phones, CAC, bandwidth control and management, and address translation
  • Voice Gateways to PSTN: Provides translation between VoIP and non-VoIP networks
  • Application Server (voice mail)
  • Conference station (voice and video)
  • IP network (router and switches)

Characteristics of Voice and Data

Voice

  • Smooth
  • Benign
  • Drop sensitive
  • Delay sensitive
  • UDP priority

Data

  • Smooth or bursty
  • Benign or greedy
  • Drop insensitive
  • Delay insensitive
  • TCP retransmits

 Video Applications

  • Cisco TelePresence
  • IP surveillance
  • Digital media systems

Characteristics of video applications

  • Most are interactive
  • Video contains voice as well
  • Requires a connection with little delay to prevent jitter
  • Requires a high-bandwidth connection depending on the video resolution
  • Peer-to-peer traffic
  • Video endpoints are connected to the access layer

Meeting the Requirements of Voice

  • Provisioning, management, and security – Voice VLAN and DHCP
  • Bandwidth, Delay/Jitter, and Packet Loss – QoS
  • Power – Power over Ethernet (PoE) and UPS
  • Availability – High availability and redundancy

Voice Implementation Steps
Voice VLAN

  • Configure voice VLANs on the access ports
  • Add voice VLANs to the trunks
  • Configure subnets for voice VLANs
  • Configure DHCP for voice subnets
  • Enable routing for voice VLANs

PoE

  • Provide PoE on access switches
  • Implement UPS

QoS

  • Implement auto QoS for VoIP

High Availability

  • Optimize the topology, routing, and redundancy

Voice VLAN Configuration

  • Switch(config)# interface fa0/4
  • Switch(config-if)# switchport mode access
  • Switch(config-if)# switchport access VLAN 10
  • Switch(config-if)# switchport voice VLAN 110
  • Switch(config-if)# spanning-tree PortFast
  • Switch(config-if)# spanning-tree bpduguard enable
  • Switch(config-if)# cdp enable

Power over Ethernet 802.3af
Two incompatible PoE detection methods

  • Cisco in-line power (2000)
  • IEEE 802.3af standard (2003)
  • TEC supports up to 15.4 W per port

New Cisco devices support both PoE methods

  • Cisco Aironet 1131AG and 1242AG access points
  • Cisco catalyst switches: 3560, 3750, 4500, and 6500 line cards okay
  • Routers with PoE: Cisco 1812 integrated services router, switch modules

Automatic detection is supported; no configuration is required

Test plan for IP phones

  • Does the IP phone receive an IP address?
  • Does the PC behind the IP phone receive an IP address?
  • Does the IP phone register with Cisco Unified Communications Manager or Cisco Unified Communications Manager Express?
  • Can you place a call to another IP phone?

High availability for VoIP and video

  • Traditional telephony networks claim 99.999% uptime
  • Real-time video applications are very sensitive to packet loss and delay
  • Data networks was considered reliability and availability requirements when incorporating voice and video
  • Methods to improve reliability and availability include:
    • Redundant hardware
    • Redundant links
    • UPS
    • Proactive network management

 Building voice, video, and data campus network

Access layer

  • Auto phone detection
  • Power over Ethernet
  • QoS: scheduling, trust boundary, and classification
  • Fast convergence

Distribution layer

  • High availability, redundancy, and fast convergence
  • Policy enforcement
  • QoS: scheduling, trust boundary, and classification

Core

  • High availability, redundancy, and fast convergence
  • QoS: scheduling and trust boundary

 Recommended Practices: QoS

  • Deployed in an end-to-end configuration
  • Ensures mission-critical apps are not impacted by links or transmit queue congestion
  • Enforces QoS policies at aggregation and great transition points
  • Uses multiple queues with configurable admission criteria and scheduling

 Layer 2 Marking: 802.p, CoS

  • The IEEE 802.1P space User Priority Field is also called Class of Service (CoS)
  • Different types of traffic are assigned different CoS values
  • CoS 6 and 7 are reserved for network use

Layer 3 marking: IP Precedence, DSCP

IPv4

  • The three most significant bits of the ToS byte are all IP precedence
  • Other gifts for unused

DiffServ

  • The six most significant bits of the ToS byte are called Diff Serv code point (DSCP)
  • DSCP is backward compatible with IP precedence
  • The remaining two bits are used for flow control

Voice VLAN configuration

  • Switch(config)# mls qos
  • Switch(config)# interface fastethernet 0/1
  • Switch(config-if)# switchport mode access
  • Switch(config-if)# switchport access vlan 10
  • Switch(config-if)# switchport voice vlan 110
  • Switch(config-if)#mls qos trust cos
  • Switch(config-if)# mls qos trust device cisco-phone

Make sure you can configure:

  • Voice VLAN
  • QoS for voice 

Make sure you are familiar with:

  • show power inline
  • show mls qos interface [fa0/1]
  • auto qos 

Understand:

  • Trust boundaries for IP telephony
  • Voice implantation plan
  • Voice test plan
  • Voice campus network – implementations at Access, Distribution, and Core
  • Recommendations practices for QoS
  • High availability for voice and video
In this article

Join the Conversation