How to Configure a Cisco Wireless Lab

Configuring a wireless lab for study and testing capabilities is a bit more involved than you might think at first glance. Most of the requirements take place on the management devices, but the underlying switch infrastructure requires some preparations as well. The tasks involved are as follows:

Step 1: LAN Switch Configuration

If you happen to have a Layer 3 PoE switch (e.g., 3560, 3750), then you have a lot of extra work done at the outset since the device itself can route between VLAN segments. If not, you may need to add a router by way of a trunk connection to perform that function for you. The ASA 5500 platform can do a few things but is not really intended for use as a routing device.

Assuming that the following is already completed, you will need to perform some specific tasks in order to support the attached wireless devices, as follows:

  1. Inline Power
    By default, power should be configured to automatically detect the attached device, but if it has been disabled, use the following commands to correct the issue:

    power inline auto Enables power detection and supply
    no shutdown Enables the interface or resets it
  2. Access Point Port Configuration
    1. Autonomous AP’sFirst decide what design you plan to use regarding single or multiple SSID’s on the AP. If you plan to only configure and use a single SSID mapped to a single VLAN, issue the following command on the attached port:
      switchport mode access Sets the port for access mode
      switchport access vlan <VLAN-ID> Identifies the VLAN to map to

      Make certain that the VLAN exists, and it doesn’t issue the following command from global configuration mode:

      vlan <VLAN-ID>

      If you plan to use multiple VLANs and SSID’s, configure the AP port for trunking mode, as follows:

      switchport trunk encapsulation dot1q Sets the trunking type
      switchport mode trunk Sets the port to trunk only mode
    2. Lightweight AP’s send traffic to specific VLANs using tunnels created between the AP and the Wireless LAN controller rather than defining VLANs on the AP itself. For that reason, set the port to access mode as follows:
      switchport mode access Sets the port for access mode
      switchport access vlan <VLAN-ID> Identifies the VLAN to map to
  3. Wireless LAN Controller Port Configuration
    Wireless LAN controllers are the “brains” behind wireless networking and have the ability to create the mappings between VLANs and SSID’s. For that reason, the port to the WLC should be configured for trunking using the following commands:

    switchport trunk encapsulation dot1q Sets the trunking type
    switchport mode trunk Sets the port to trunk only mode

Step 2: Wireless LAN Controller Initial Configuration

To perform the very initial configuration on the WLC-2106, you will need to be connected to the console port of the device using a terminal services client. Most of the process is menu-driven, so knowing the command syntax is not a hard requirement. Keep in mind that the Command Line Interface (CLI) is IOS-like but not identical, so it can take some getting used to. The WLC will go through some boot processes, but eventually you will see the following displayed:

Booting Primary Image…
Press <ESC> now for additional boot options…

If the device has not had its configuration erased, press break or Control-R, and then press the ESC key, which will display the following menu:

  1. Run primary image (active)
  2. Run backup image (Version x.x.x.x)
  3. Manual upgrade primary image
  4. Change active boot image
  5. Clear configuration
  6. Please enter your choice:

Select 5 to clear the configuration and reset everything to factory defaults.

Whether you reset the device or you are powering it up with no configuration, you’ll be prompted through a series of questions designed to enable the WLC for use, as follows:

  1. System Name:  Basically the hostname of the WLC-2061
  2. Administrative User Name:  Username of the system administrator (default is admin)
  3. Administrative User Password: Password of the system administrator (default is admin)
  4. Management Interface IP Address: The first of several IP addresses required, this is one of the most important ones as you will access the web GUI by this address
  5. Management Interface Netmask: Mask of the previously configured IP address
  6. Management Interface Default Router: Layer 3 default gateway on the Management VLAN
  7. Management Interface VLAN Identifier:  VLAN-ID of the management VLAN, leave at 0 to leave traffic untagged (simpler and easier for a lab environment)
  8. Management Interface Port Number: Not a TCP/UDP port but the physical port connected to the upstream LAN switch (see numbers on the back of the WLC)
  9. Management Interface DHCP Server IP Address:  DHCP server on the Management VLAN
  10. AP Manager Interface IP Address: This is the IP address and subnet that will be used to communicate with the AP’s
  11. Virtual Gateway IP Address: This is a fictitious address for purposes of mobility management and some other functions, most administrators tend to use 1.1.1.1
  12. Mobility/RF Group Name: Optional, not needed for this lab environment
  13. Network Name (SSID): Default SSID that Lightweight AP’s use to join the controller
  14. Allow Static IP Addresses: Specifies whether or not clients are forced to use DHCP
  15. Configure a RADIUS Server Now? Yes/No whether or not to add a RADIUS server for security purposes (leave at no unless you have added it to your lab)
  16. Enter Country Code: This indicated the area where the wireless will be deployed, using a two letter code (the US is default)
  17. Enable 802.11b Network: Yes/No as to whether to enable the 802.11b (2.5 GHz) RF network
  18. Enable 802.11a Network: Yes/No as to whether to enable the 802.11a (5 GHz) RF network
  19. Enable 802.11g Network: Yes/No as to whether to enable the 802.11g (2.5 GHz) RF network
  20. Enable Auto-RF: Yes/No as to whether to enable Radio Resource Management

Step 3: Wireless Control System Initial Configuration

The Wireless Control System (WCS) can run on any one of three operating system environments, namely Windows, Linux Red Hat, or VMware ESX Server. The biggest hurdle with using Windows is that a Server OS is required, which in a production environment isn’t optional. There is a workaround to use Windows XP, which is fine for a lab environment. The trick is to go to the Windows Command Prompt and enter the following:

<WCS Filename> -DCHECK_OS=false

An actual example would be C:\WCS-STANDARD-K9-5.2.130.0.EXE -DCHECK_OS=false

I actually did this on a Toshiba Netbook running Windows XP Pro, and it worked fine. My issue only had to do with using an underpowered machine. Once WCS is installed, you can reach it using the IP address assigned to the laptop. Log into the WLC GUI, and perform the integration between the WLC and WCS, and you will be good to go.

Step 4: Access Point Configuration

The Lightweight AP’s should be ready to go if they are already imaged to lightweight mode and set to get their addresses through DHCP. If you DO have to reimage the access points (for instance, from autonomous mode) then the procedure is available on Cisco.com. To make your autonomous AP, log in through the console port and assign an IP address to the Bridged Virtual Interface (BVI). Following that, you should be able to get access through that IP using the web GUI.

That should get you prepared to perform Wireless LAN lab exercises and give you a great start on learning this exciting technology!

In this article

Join the Conversation