Quality of Service Part 14 – MQC Pop Quiz Answer

Entry number 13 of this series offered a challenging pop quiz on how to configure QoS on a Cisco router using Modular QoS Command Line Interface (MQC) queuing mechanisms.

Here is the pop quiz question with the answer in the CLI output below.

Author: Paul Stryer

On the HQ WAN router, configure the appropriate MQC based queuing mechanism for the outbound traffic to the WAN s0/0, so that the following requirements will be met.

Only add the QoS commands to the below configuration, assume everything else needed for the network is finished or will be put in later.

  • Class Map for voice that matches RTP, EF, CS3, and AF31
  • Class Map for Bulk that matches FTP, and aF11
  • Class map for Interactive that matches Citrix, and af21
  • Name the policy: qos-policy
  • Voice Traffic: 128 Kbps Maximum, use the IOS default burst values
  • Interactive Traffic: 30 Kbps minimum
  • Bulk Traffic: 24 Kbps minimum, also limit traffic to an average rate of 24 kbps by buffering excess traffic. Use the IOS default BC and BE
  • Class-Default: Weighted Fair Queue with no bandwidth guarantee

Here is the basic configuration of the HQ router.

HQ#sh run
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HQ
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
multilink bundle-name authenticated
!
archive
log config
hidekeys
!

class-map match-any bulk match protocol ftp match ip dscp af11 class-map match-any interactive match protocol citrix match ip dscp af21 class-map match-any voice match protocol rtp match ip dscp cs3  af31  ef ! policy-map qos-policy class voice priority 128 class interactive bandwidth 30 class bulk bandwidth 16 shape average 24000 class class-default fair-queue !
interface FastEthernet0/0
ip address 192.168.100.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
bandwidth 384
ip address 10.11.12.1 255.255.255.254
encapsulation ppp
clock rate 2000000
service-policy output qos-policy
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
!
webvpn cef
!
end
In this article

Join the Conversation