Quality of Service Part 13 – MQC Pop Quiz

The past 12 entries of this blog series have explored QoS theory and how to configure QoS on Cisco routers. By popular demand, I have created a pop quiz on how to configure QoS on a Cisco router using Modular QoS Command Line Interface (MQC) queuing mechanisms.

Here is how the pop quiz will work. The question will be posed in this entry, number 13 in the QoS series. You can post your answers in the comments section below this text. The answer to the question will be posted in entry number 14 of this QoS series.

Here is the pop quiz question – Good Luck!

Author: Paul Stryer

On the HQ WAN router, configure the appropriate MQC based queuing mechanism for the outbound traffic to the WAN s0/0, so that the following requirements will be met.

Only add the QoS commands to the below configuration, assume everything else needed for the network is finished or will be put in later.

  • Class Map for voice that matches RTP, EF, CS3, and AF31
  • Class Map for Bulk that matches FTP, and aF11
  • Class map for Interactive that matches Citrix, and af21
  • Name the policy: qos-policy
  • Voice Traffic: 128 Kbps Maximum, use the IOS default burst values
  • Interactive Traffic: 30 Kbps minimum
  • Bulk Traffic: 24 Kbps minimum, also limit traffic to an average rate of 24 kbps by buffering excess traffic. Use the IOS default BC and BE
  • Class-Default: Weighted Fair Queue with no bandwidth guarantee

Here is the basic configuration of the HQ router.

HQ#sh run
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HQ
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
interface FastEthernet0/0
ip address 192.168.100.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
bandwidth 384
ip address 10.11.12.1 255.255.255.254
encapsulation ppp
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
!
webvpn cef
!
end
In this article

Join the Conversation

1 comment

  1. Kemal Sanjta Reply

    Hi,

    Here is the configuration required as per your request:

    HQ> enable
    HQ#conf t
    HQ(config)#class-map voice
    HQ(config-cmap)#match protocol rtp
    HQ(config-cmap)#match dscp ef
    HQ(config-cmap)#match dscp cs3
    HQ(config-cmap)#match dscp af31
    HQ(config-cmap)#exit
    HQ(config)#class-map bulk
    HQ(config-cmap)#match protocol ftp
    HQ(config-cmap)#match dscp af11
    HQ(config-cmap)#exit
    HQ(config)#class-map interactive
    HQ(config-cmap)#match protocol citrix
    HQ(config-cmap)#match dscp af21
    HQ(config-cmap)#exit
    HQ(config)#policy-map qos-policy
    HQ(config-pmap)#class voice
    HQ(config-pmap-c)#priority 128
    HQ(config-pmap-c)#exit
    HQ(config-pmap)#class interactive
    HQ(config-pmap-c)#bandwidth 30
    HQ(config-pmap-c)#exit
    HQ(config-pmap)#class bulk
    HQ(config-pmap-c)#bandwidth 24
    HQ(config-pmap-c)#shape avarage 24000
    HQ(config-pmap-c)#exit
    HQ(config-pmap)#class class-default
    HQ(config-pmap-c)#fair-queue
    HQ(config-pmap-c)#exit
    HQ(config-pmap)#exit
    HQ(config)#interface serial 0/0
    HQ(config-if)#service-policy output qos-policy

    Since we have configured bandwidth command on bulk class, it would be enough to put just “shape avarage” within policy map.

    Best regards,
    Kemal Sanjta